» » » Tekrar eden satırları benzersiz olarak diğer sütuna aktarmak

Tekrar eden satırları benzersiz olarak diğer sütuna aktarmak

Çözüldü
Merhaba Arkadaşlar,
Elimde bir tablo var, bu tabloda satır olarak sürekli tekrar eden değerler var, günlük olarak ben bu değerleri yanda ayrı bir sütunda görmek istiyorum, sonrasında da etopla formülü ile satırlara karşılık gelen değerleri toplayacağım.

Tekrar etmeyen satır değerlerini sağ tarafta nasıl görebilirim
Teşekkürler
23.11.2020, 16:38 1 cevap 175 okunma +3
Bilgilendirme! Cevap ve yorum yazabilmeniz için sitemizde üye kaydınızın olması gerekmektedir.
    • Admin
      10:54, 24 Kasım 2020
      1
      Şikayet Et

      Merhaba,

      Kullandığınız ofis sürümünü bilmiyorum, bildiğim kadarıyla Office 365 sürümünde sizin yapmak istediğiniz için düşünülmüş fonksiyon hazır olarak geliyor. Türkçe sürümlerde "BENZERSIZ", İngilizce sürümlerde "UNIQUE" olarak kullanabiliyorsunuz.
      Kullandığınız sürümde olmadığını kabul edersek, bunu en pratik şekilde makro kullanarak yapabilirsiniz.
      Function BENZERSIZ(rng As Range) As Variant()
      Dim list As New Collection
      Dim Ulist() As Variant

      On Error Resume Next
      For Each Value In rng

      list.Add CStr(Value), CStr(Value)
      Next
      On Error GoTo 0
      ReDim Ulist(list.Count - 1, 0)

      For i = 0 To list.Count - 1
      Ulist(i, 0) = list(i + 1)
      Next

      BENZERSIZ = Ulist
      End Function

      Bu kodu ekledikten sonra, çalışma yapacağınız sayfanızda =BENZERSIZ(A1:A10) şeklinde kullanabilirsiniz. Formülün kapanışını yaparken, bir dizi işevi olması dolayısıyla CTRL+SHIFT+ENTER yaparak işlemi tamamlayabilirsiniz.

      Makro kullanmak istemezseniz, 2.yol olarak aşağıdaki excel formülü ile yapabilirsiniz.

      =EĞERHATA(İNDİS($A$2:$A$16;KAÇINCI(0;EĞERSAY($B$1:B1;$A$2:$A$16););"")